Aufbau von 3 GBA-1000 - Die drei Schwestern




Nachdem ich mich irgendwie freiwillig gemeldet hatte 3 GBAs mit Turbokarte aufzubauen, war mir das komplette Ausmaß dieser leichtfertigen Zusage nicht ganz bewusst.

Aktueller Projekt-Status:

Bauteil Aufgebaut Programmiert Läuft
GBA #1 JA JA JA
GBA #2 JA JA JA
GBA #3 JA JA JA
TK #1 JA JA JA
TK #2 JA JA JA
TK #3 JA JA NEIN
USB #1 JA JA NEIN
USB #2 JA JA NEIN
USB #3 NEIN NEIN NEIN



Teileimpressionen:
Am 01.09. bekam ich Post von halbvier:


Die Boards hatte ich ja im Vorfeld schon erhalten. Ausgepackt offenbart sich der ganze Umfang. Hier sieht man 3 Sätze für GBA-Boards und 3 Sätze für die 68060-Turbokarte:


Da leider einige Teile im Board-Satz fehlten, habe ich zuerst mal eine Turbokarte gelötet, quasi zum aufwärmen:

Hier ohne Lüfter und Kühler:

Und noch mit angelötetem Floppykabel zur Spannungsversorgung. Eigentlich sollte es eine Steckverbindung sein, ich habe mich aber entschieden, diese Seite auf das Board zu löten. So kann man den Anschluß nicht falsch aufstecken:

Dann kamen die restlichen Teile und ich habe mit dem ersten Board begonnen:

Hier der erste Startversuch, auf dem Bildschirm sieht man einen roten Screen. Zumindest ein Lebenszeichen:

Nach einigem Suchen und dem Austausch einiger GALs lief das Board endlich an:

Motiviert ging es an Board #2:

Hier ergaben sich etliche Probleme mit dem Chip-Ram. Ich hab das Chip-Ram dann kurzerhand gegen Chips von einem PS/2 Modul ausgetauscht.

Hier sieht man Board #1 und Board #2 nebeneinander:

Board #1 mit fertig bestütem SRAM:

... und #1 mit 060er Karte:

SysInfo zeigt noch etwas niedrige Werte an:

Dies liegt an den fehlenden MMU-Tools und einigen falschen Libraries. Richtig konfiguriert geht die Turbokarte ab, wie eine Rakete:

WhichAmiga zeigt auch den korrekten Takt der CPU an:

Auf zur Turbokarte #2! Hier teilbestückt (der CPU-Sockel ist nur lose eingesetzt):

Und fertig gelötet:

Turbokarte #1 und #2 nebeneinander, die dritte CPU lauert schon im Hintergrund:

GBA #2 mit Turbokarte #2:

GBA #1 und #2, jeweils mit Turbokarten:

GBA #3, das Sorgenkind. Zuerst wollte gar nichts laufen, hier mit angeklemmtem Logic Analyzer:

Nach einigem Hin und her mit dem Chip-Ram (wie bei GBA#2) lief dann #3 endlich! Hier mit dem Logica Rom. Mr. Data ist erfreut:

Nach dem Bestücken des IDE-Controllers gabs erneut Probleme. Also wieder an den Logic Analyzer:

Nach einigen Tests und Verzweiflungstaten lief der GBA #3 endlich auch mit IDE-Controller! Hier fehlt noch das SRAM. Mr. Spock ist entsetzt über die mageren 559 Dhrystones in SysInfo:

Auflöten des SRAMs bei GBA #3:

Mit SRAM sieht das Ganze dann schon besser aus. Der Test lief nur mit einem 40MHz-Quarz, ich hatte leider nur eine CPU, die mit 50MHz stabil lief. Für die Tests aber kein Problem, immerhin kommt da ja eine Turbokarte drauf:

Turbokarte #3. Die Spannungsversorgung ist schon bestückt und läuft, der erste CPLD ist gerade frisch aufgelötet:

Hier die 3 CPLDs, bereit zum Programmieren. Am Kabel hängt schon der JTAG-Programmer:

Alle drei Turbokarten im Gruppenbild:

Hier GBA #2 im Gehäuse. Für Testzwecke wurde der Rechner kurzzeitig wieder auf 68030 zurückgebaut:

Hier noch die drei Leerplatinen für die GBA-Thylacine: